System Requirements

We design Scalyr to work with the the latest web browsers. Specifically, we support the current version and the previous major version of the following browsers:

We recommend the latest stable build of Chrome.

By keeping our list of supported browsers limited, we can focus on delivering the best experience to our users.

If you are encountering issues with the web site or the product, we recommend clearing cache, restarting your browser, and disabling any extensions.